| HOME | 

Windows VistaでTelnetを使いたい!
このスレッドはロックされています。記事の閲覧のみとなります。
トップページ > 記事閲覧
Windows VistaでTelnetを使いたい!   
まこすけ
2007/06/12 20:21:41

もうすっかり忘れてしまったので復習も兼ねてCiscoルータを取り出してCiscoルータで遊んでいたら、Windows VistaでTelnetが使えないのに気が付きました。ネットで調べてみると、Windows VistaはデフォルトでTelnetが無効になっているそうです。そこで今回はWindows VistaでTelnetを使えるようにしたいと思います。




では、早速やってみよう。


■ Windows VistaのIPアドレス: 192.168.0.5
■ CiscoルータのIPアドレス: 192.168.0.6

(CiscoルータはTelnetできるように設定済み)




まず、何も設定変更をしていない状態でTelnetを使うとどうなるかやってみるね。

コマンドプロンプトを開いて「telnet 192.168.0.6」と入力し、エンター。





'telnet' は、内部コマンドまたは外部コマンド、
操作可能なプログラムまたはバッチ ファイルとして認識されていません。


だって。そうなんだ。telnetコマンド自体が使えないんだよね。







では、これから使えるように変更してみるね。




「コントロールパネル」 → 「プログラム」 → 「Windows の機能の有効化または無効化」をクリック。








Windows Vistaは、Telnetクライアントの他にTelnetサーバー機能もあるんだね。
Telnetクライアントが終わったら、Telnetサーバーも後からやってみよう。






Telnetクライアントにチェックを入れて「OK」をクリック。









ではまたTelnetをやってみよう。

Windows VistaからCiscoルータにTelnetしてみるね。



コマンドプロンプトを開いて「telnet 192.168.0.6」と入力し、エンター。





おっ、パスワードを聞いてきた。
Windows VistaでTelnetクライアントの機能は有効になったってことだね。


Ciscoルータに設定したVTYパスワード(Telnetパスワード)を入力し、エンター。





やったー、プロンプトが Router> になった!
CiscoルータにTelnet成功!




記念にshow versionコマンドでもしておこう。







Ciscoルータのshow versionもきちんと表示されたから、logoutコマンドでTelnetを抜けておこう。









Windows VistaのTelnetクライアントの機能はこれで有効になったとこが確認できたね。今日はこれだけを有効にしたかったけど、せっかくだからTelnetサーバーの機能も試してみよう。




再度、「コントロールパネル」 → 「プログラム」 → 「Windows の機能の有効化または無効化」をクリック。











今回は、Telnetサーバーにチェックを入れて「OK」をクリック。









では今度は、CiscoルータからWindows VistaにTelnetしてみよう。

CiscoルータはTeraTerm Proというターミナルソフトを使うんだよ。





TeraTerm Proの使い方やどういうものかは今回は省いちゃうけど、もし興味のある人は「自宅ラボ構築計画」を見てくださいね。



TeraTerm Proのウィンドウで「telnet 192.168.0.5」と入力し、エンター。





% Connection timed out; remote host no responding か。
Windows Vistaからの返事がないってことだね。






Windowsの機能でTelnetサーバーを有効にするだけじゃ駄目なんだね。
どうすれば、Telnetサーバー機能が有効になるんだろう。


そういえば、Windowsのサーバー機能はサービスとして実行されているって何かの本で読んだことがあったな。そうか、サービスか。よしサービスを見てみよう。



「コントロールパネル」 → 「システムとメンテナンス」 → 「管理ツール」をクリック。





「サービス」をダブルクリック。









「Telnet」が無効になってるね。だから駄目だったんだね。これを有効にするね。

「Telnet」をダブルクリック。





現在、起動時に「無効」になっていて、これを「自動」や「手動」にすることができるんだけど、Telnetサーバー機能を頻繁に使うのでなければ「自動」にしておく必要はないよね。





「手動」を選び「適用」をクリック。





そうすると「開始」ボタンが押せるようになるので「開始」をクリック。





Telnetサーバーのサービスが開始したね。では「OK」をクリック。








ではWindows VistaへのTelnetを再チャレンジしてみよう。



TeraTerm Proのウィンドウで「telnet 192.168.0.5」と入力し、エンター。





やったー! ログインプロンプトがでたよ。






ここでユーザー名とパスワードを入れなきゃいけないと思うんだけど、まこすけのユーザー名とパスワードでいいのかな? Telnetで使うユーザーアカウントって登録してないよね。まあ、いいか。とりあえず、まこすけのユーザー名とパスワードを入力しちゃお。



「まこすけ」と入力し、エンター。





まこすけのパスワードを入力し、エンター。





「Login Failed」だって。やっぱり駄目か。






たぶん、「まこすけ」のユーザーアカウントをTelnetで使えるように登録しなくちゃいけないんだよね。こういう時は、コンピュータの管理の「ユーザーとグループ」だよね。



「スタートメニュー」 → 「コンピュータ」を右クリックして「管理」をクリック。








グループを見てみよう。






「ローカルユーザーとグループ」 → 「グループ」をクリック。






やっぱりあった! TelnetClientsグループだって。これだね。


このグループに「まこすけ」を入れよう。
TelnetClientsグループをダブルクリックし「追加」をクリック。









「まこすけ」を入力し「OK」をクリック。





「OK」をクリック。









よしこれで「まこすけ」はTelnetで使えるユーザーアカウントになったね。

ではまたまたWindows VistaへのTelnetを再チャレンジしてみよう。



TeraTerm Proのウィンドウで「telnet 192.168.0.5」と入力し、エンター。





Login:に「まこすけ」と入力し、password:に「まこすけ」のパスワードを入力し、エンター。






やっぱり「Login Failed」か。。。


「まこすけ」をTelnet用のユーザーアカウントにしたのに何故かな?

ユーザーアカウントが「ひらがな」なのがいけないのかな?

やっぱり「アルファベット」にしないといけないのかな?

まてよ・・・「ひらがな?」「漢字?」「日本語?」・・・もしかして「文字コード」???




よし「文字コード」を変えてみよう。




TeraTerm Proのメニューバーの「設定」 → 「端末」をクリック。





現在は「UTF-8」になってるね。これを他のものに変更してみよう。



やっぱりWindowsは「SJIS」かな?
「SJIS」を選んで「OK」をクリック。






ではまたまたまたWindows VistaへのTelnetを再チャレンジしてみよう。



Login:に「まこすけ」と入力し、password:に「まこすけ」のパスワードを入力し、エンター。







やったー、ログインンに成功した!
「Micorosoft Telnet Server」だって。

プロンプトも D:\Users\まこすけ> になってる。
Windows VistaにTelnet成功!





では今回はdirコマンドでもしておこう。





ちゃんとディレクトリが見えてるね。


Windows VistaのTelnetサーバー機能も確認できたからlogoutコマンドでTelnetを抜けておこう。





あれ?

'logout' は、内部コマンドまたは外部コマンド、
操作可能なプログラムまたはバッチ ファイルとして認識されていません。


だって。logoutコマンドはサポートしてないのかな?
だったらExitコマンドで抜けよう。






OK、抜けれたね。無事成功。




思ったより時間がかかっちゃったけど、Windows VistaのTelnetサーバー機能も確認できたし良かったね。


でも、Telnetサーバー機能がデフォルトで無効なのはわかるけど、どうしてTelnetクライアント機能も無効なのかな? Telnetクライアント機能が有効だとセキュリティ上問題があるのかな? もしVista実験室をやってなかったら、僕はWindows VistaではTelnetは使えないと思ってあきらめちゃったかもしれないな。


どんどん便利になっていっているのか、不便になっていっているのか、
わからないね、Windows・・・


スレッド修正

Page: 1 |

Re: Windows VistaでTelnetを使いたい! ( No.1 )   
yutaka064
2010/01/06 17:41:20

telnetの設定がうまく接続できません。何度も設定をしましたが、
接続失敗!になります。
どうしたらいいでしょうか?

記事修正
Re: Windows VistaツづTelnetツづーツ使ツつ「ツつスツつ「ツ! ( No.2 )   
Shorty
2011/04/15 16:32:02

That's 2 clever by half and 2x2 clever 4 me. Tahkns!

記事修正
Re: Windows VistaでTelnetを使いたい! ( No.3 )   
ametyan
2011/04/16 12:09:07

接続自体はうまくいったのですが、
入力バックスペース押下時に画面の文字が正しく消えません。
(カーソルが左に移動し、画面の表示が変わらない)
どうしたらよいでしょうか?

記事修正

Page: 1 |